Issues

  • Requests being blocked by CORS

    Hi We have received notifications that requests to the CLA API are not working. Upon investigating, it appears the preflight request is returning a 404, so the subseequent request to the API fails due to no "Access-Control-Allow-Origin" header having been received. Can you please advise? Many thanks Andrew Isherwood

    Status: Proposed | Reported by Thu, 14 Oct 2021 10:11:59 GMT
  • Requests being blocked by CORS

    Hi We have been receiving reports from customers that our CLA Permission Check integration isn't working. I've had a look into it and can see that the requests are being blocked by CORS. The requests are being redirected from the URL your documentation states (https://api.cla.co.uk/check-permissions/v1/) to a new URL (https://cla-copyright-api.azurewebsites.net/restful-services/clacopyrightservices/public/). However, the response to a preflight request to the new URL isn't allowing use of the "ocp-apim-subscription-key" header. The old URL correctly returned "Access-Control-Allow-Headers: ocp-apim-subscription-key", but the new URL does not. Could you please advise? Many thanks Andrew Isherwood PTFS Europe

    Status: Proposed | Reported by Fri, 12 Mar 2021 10:52:29 GMT
  • GetCourses error since 11/01/20201

    The GetCourses endpoint, and possibly others, has not been working since at least 11/01/20201. It was working for us before that date. I've also tested with Postman and I get the following response: { "status": "error", "status-code": 4, "status-message": "Internal server error - please contact admin" }

    Status: Resolved | Reported by Tue, 12 Jan 2021 14:07:24 GMT
  • API intermittently not responding

    Hi, We had recent cases where it seems the API is not responding. Are you aware of any current issues? Many thanks, Jochen

    Status: Resolved | Reported by Mon, 29 Oct 2018 11:56:55 GMT
  • Both REST and SOAP APIs not responding

    Hello, Neither the REST nor SOAP APIs have responded to requests since 18:44 19/06. Thank you.

    Status: Resolved | Reported by Tue, 19 Jun 2018 18:26:00 GMT

You're not signed in. Please sign-in to report an issue or post a comment.